Comment maîtriser les fonctions Recherche H et Recherche V sur Excel ?

Recherche H et Recherche V

Aujourd’hui on s’attaque au duo le plus célèbre depuis la faucille et le marteau : les fonctions recherche H et recherche V sur Excel. Très utilisées en entreprise elles doivent être parfaitement maitrisées, pour cela entrainez-vous avec l’exercice du fichier à télécharger ici. Cet article complète celui sur les 10 astuces Excel pour briller en stage !

 

La fonction Recherche H sur Excel

RECHERCHEH est une fonction qui recherche une valeur A dans la première ligne d’un tableau et affiche la valeur B d’une cellule se trouvant dans la même colonne que la valeur A. Comme son nom l’indique, il s’agit d’une recherche horizontale.

Elle s’écrit =RECHERCHEH(la valeur cherchée A; le tableau ;la ligne où se trouve la valeur B ; approximation ou non)

Exemple de fonction Recherche H

A partir du tableau ci-dessus, une recherche H peut par exemple, à partir du nom d’un manager, renvoyer son âge ou son salaire.

Ainsi, si l’on veut afficher l’entreprise de Lucie on remplace :

la valeur cherchée A par : E1 ou « Lucie » (il s’agit ici de définir dans quelle colonne la valeur B doit être cherchée)

le tableau par : A1:E7 (attention, la valeur A est systématiquement dans la première ligne du tableau)

la ligne où se trouve la valeur B par : 5

approximation : FAUX (ici Excel nous demande si l’on souhaite chercher la valeur la plus proche de A dans le cas où il n’y aurait pas exactement la valeur A)

Ainsi, si l’on saisit =RECHERCHEH(E1;A1:E7;5;FAUX), Excel renvoie Hermès.

De même, si l’on saisit =RECHERCHEH(« Ali »;A1:E7;3;FAUX), Excel renvoie Marketing.

 

La fonction Recherche V

RECHERCHEV est une fonction qui recherche une valeur A dans la première colonne d’un tableau et affiche la valeur B d’une cellule se trouvant dans la même ligne que la valeur A. Comme son nom l’indique, il s’agit d’une recherche verticale.

Elle s’écrit =RECHERCHEV(la valeur cherchée A; le tableau ;la colonne où se trouve la valeur B ; approximation ou non)

 

Exemple de fonction Recherche V

On peut à partir du tableau faire afficher la ristourne de Toyota grâce à l’utilisation de la fonction RechercheV.

la valeur cherchée A par : A4 ou « Toyota » (il s’agit ici de définir dans quelle ligne la valeur B doit être cherchée)

le tableau par : A1:E5 (attention, la valeur A est systématiquement dans la première colonne du tableau)

la colonne où se trouve la valeur B par : 3 (c’est la 3ème colonne)

approximation : FAUX (ici Excel nous demande si l’on souhaite chercher la valeur la plus proche de A dans le cas où il n’y aurait pas exactement la valeur A)

Ainsi, si l’on saisit =RECHERCHEV(A4;A1:E5;3;FAUX), Excel renvoie 0.

De même, si l’on saisit =RECHERCHEV(« Vinci »;A1:E5;5;FAUX), Excel renvoie Claude.

 

Conclusion

Pour voir si tu es au point sur l’application concrète de ces deux fonctions, tu peux faire l’exercice dans le fichier Excel à télécharger ici.

Les fonctions recherche H et recherche V sont indispensables mais présentent de nombreuses limites qui pourront être dépassées par les fonctions Excel Index et Equiv. Cette fonction est plus adaptée pour des tables de données plus complexes que celles pour lesquelles on utilise Recherche H et Recherche V.

Te voilà désormais armé pour affronter Excel!