Accueil Carrière Comment maîtriser les Recherche H et V sur Excel ?

Comment maîtriser les Recherche H et V sur Excel ?

0
658

Aujourd’hui on s’attaque au duo le plus célèbre depuis la faucille et le marteau : les recherches H et V. Très utilisées en entreprise elles doivent être parfaitement maitrisées, pour cela entrainez-vous avec l’exercice du fichier à télécharger ici.  Par ailleursTu peux retrouver le premier article sur Excel ici 😉 !

 

Recherche H, définition

RECHERCHEH est une fonction qui recherche une valeur A dans la première ligne d’un tableau et affiche la valeur B d’une cellule se trouvant dans la même colonne que la valeur A.

Elle s’écrit =RECHERCHEH(la valeur cherchée A; le tableau ;la ligne où se trouve la valeur B ; approximation ou non)

Exemple

A partir du tableau ci-dessus, une recherche H peut par exemple, à partir du nom d’un manager, renvoyer son âge ou son salaire.

Ainsi, si l’on veut afficher l’entreprise de Lucie on remplace :

la valeur cherchée A par : E1 ou “Lucie” (il s’agit ici de définir dans quelle colonne la valeur B doit être cherchée)

le tableau par : A1:E7 (attention, la valeur A est systématiquement dans la première ligne du tableau)

la ligne où se trouve la valeur B par : 5

approximation : FAUX (ici Excel nous demande si l’on souhaite chercher la valeur la plus proche de A dans le cas où il n’y aurait pas exactement la valeur A)

Ainsi, si l’on saisit =RECHERCHEH(E1;A1:E7;5;FAUX), Excel renvoie Hermès.

De même, si l’on saisit =RECHERCHEH(“Ali”;A1:E7;3;FAUX), Excel renvoie Marketing.

 

Recherche V, définition

RECHERCHEV est une fonction qui recherche une valeur A dans la première colonne d’un tableau et affiche la valeur B d’une cellule se trouvant dans la même ligne que la valeur A.

Elle s’écrit =RECHERCHEV(la valeur cherchée A; le tableau ;la colonne où se trouve la valeur B ; approximation ou non)

Exemple

On peut à partir du tableau faire afficher la ristourne de Toyota.

la valeur cherchée A par : A4 ou “Toyota” (il s’agit ici de définir dans quelle ligne la valeur B doit être cherchée)

le tableau par : A1:E5 (attention, la valeur A est systématiquement dans la première colonne du tableau)

la colonne où se trouve la valeur B par : 3 (c’est la 3ème colonne)

approximation : FAUX (ici Excel nous demande si l’on souhaite chercher la valeur la plus proche de A dans le cas où il n’y aurait pas exactement la valeur A)

Ainsi, si l’on saisit =RECHERCHEV(A4;A1:E5;3;FAUX), Excel renvoie 0.

De même, si l’on saisit =RECHERCHEV(“Vinci”;A1:E5;5;FAUX), Excel renvoie Claude.

 

Conclusion

Pour voir si tu es au point fais l’exercice dans le fichier Excel à télécharger ici. Les recherches H et V sont indispensables mais présentent de nombreuses limites qui pourront être dépassées par les fonctions Index/Equiv. Nous aborderons ces notions dans un prochain article.